Repository navigation
Repair wp/5.9 branch Actions: Pin phpunit/phpunit to a PHP 5.6/7.0-compatible release - #619
Closed
desrosj wants to merge 1 commit into
Conversation
desrosj
added this pull request to stack #616
October 6, 2026 13:53
🤖 PR meta 🤖🏷️ LabelsThis pull request needs exactly one label indicating its type, and has 0.
Read more about Type labels in Gutenberg. If you cannot add labels yourself, a reviewer can do it for you. |
desrosj
force-pushed
the
fix-actions-5.9/fix-phpunit-dev-dependency-floor
branch
from
October 6, 2026 17:49
78eeca5 to
25ccdcc
Compare
desrosj
removed this pull request from stack #616
October 6, 2026 18:27
desrosj
added this pull request to stack #636
October 6, 2026 18:28
desrosj
removed this pull request from stack #636
October 7, 2026 00:58
desrosj
added this pull request to stack #643
October 7, 2026 00:59
desrosj
removed this pull request from stack #643
October 7, 2026 18:02
desrosj
changed the base branch from
fix-actions-5.9/fix-setup-teardown-polyfills
to
wp/5.9
October 7, 2026 18:02
desrosj
force-pushed
the
fix-actions-5.9/fix-phpunit-dev-dependency-floor
branch
from
October 7, 2026 18:04
25ccdcc to
5f65e08
Compare
desrosj
changed the base branch from
wp/5.9
to
fix-actions-5.9/fix-setup-teardown-polyfills
October 7, 2026 18:06
desrosj
added this pull request to stack #668
October 7, 2026 18:06
desrosj
force-pushed
the
fix-actions-5.9/fix-phpunit-dev-dependency-floor
branch
from
October 8, 2026 18:17
5f65e08 to
2b90e73
Compare
desrosj
removed this pull request from stack #668
October 8, 2026 19:35
desrosj
force-pushed
the
fix-actions-5.9/fix-phpunit-dev-dependency-floor
branch
from
October 8, 2026 19:35
2b90e73 to
206c61a
Compare
desrosj
added this pull request to stack #695
October 8, 2026 19:35
desrosj
marked this pull request as ready for review
October 9, 2026 16:38
|
The following accounts have interacted with this PR and/or linked issues. I will continue to update these lists as activity occurs. You can also manually ask me to refresh this list by adding the If you're merging code through a pull request on GitHub, copy and paste the following into the bottom of the merge commit message. To understand the WordPress project's expectations around crediting contributors, please review the Contributor Attribution page in the Core Handbook. |
Owner
Author
|
Moved to WordPress#84415. |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
What?
phpunit/phpunitdev dependency from^8.5to^5.7(resolves to5.7.27), so thePHP 5.6unit test jobs can load the plugin's Composer autoloader.config.platform.phpfrom8.1to5.6.20, and ignores four Composer advisories, so that version can resolve.composer.lockwithcomposer update phpunit/phpunit --with-all-dependencies.Why?
Both
PHP 5.6jobs fail before any test runs:wp-phpunit/wp-phpunitcallsclass_exists( 'PHPUnit\Runner\Version' ), which loads the class from the lockedphpunit/phpunit8.5.21. Its return type declarations don't parse on PHP 5.6. PHPUnit 5.7.27 has no namespacedPHPUnit\Runner\Version, so the check returnsfalseandwp-phpunitfalls back toPHPUnit_Runner_Version.wp/6.0makes the same change in WordPress#84281. This branch also needs:config.platform.php5.6.20: PHPUnit 5.7 requires PHP^5.6 || ^7.0, so it can't resolve against the8.1set in Repairwp/5.9branch Actions: Let the current Composer release install this branch's dependencies #341.5.6.20is the matrix's lowest PHP version and Repairwp/5.9branch Actions: Let the current Composer release install this branch's dependencies #341'srequire.phpfloor. With7.4, Composer would picksymfony/yamlandsymfony/polyfill-ctypereleases that need PHP 7.1+. The platform change can't go in Repairwp/5.9branch Actions: Let the current Composer release install this branch's dependencies #341, because PHPUnit^8.5needs PHP 7.2+.PKSA-z3gr-8qht-p93vmatches everyphpunit/phpunitbelow 8.5.52, andPKSA-v5yj-8nmz-sk2q,PKSA-ft77-7h5f-p3r6andPKSA-b14r-zh1d-vdrcmatch everysymfony/yaml2.x–4.x, which PHPUnit 5.7 requires. The reasons recorded are the same as onwp/6.0.How?
Only
phpunit/phpunit's dependency tree changes incomposer.lock: 22 packages updated,phpunit/phpunit-mock-objects3.4.4 andsymfony/yamlv3.4.47 added, and fivephar-io/sebastian/theseerpackages removed.wp-phpunit/wp-phpunit5.9.17,yoast/phpunit-polyfills,composer/installersand the PHPCS packages keep their versions.The PHP 7.4, 8.0 and 8.1 jobs use the PHPUnit bundled in their Docker image, not the one in
vendor.Testing
composer updatewith Composer 2.10.3 resolves as above, andcomposer install --no-interactionsucceeds.vendor/composer/autoload_files.phpand PHPUnit'sRunner/Version.phppassesphp -l.class_exists( 'PHPUnit\Runner\Version' )returnsfalse, andPHPUnit_Runner_Version::id()returns5.7.27.Use of AI Tools
This PR was created by Claude Code under my supervision. All code should be treated as AI-produced and not yet reviewed by a human until this PR is marked Ready for Review.
🤖 Generated with Claude Code